4Sleep and WOL with Intel 82567LM-3

I have a couple of old USFF Dell Optiplex 760 PCs that have a built-in Intel 82567LM-3 gigabit ethernet connection. Getting this adapter to work with both Sleep (S3 Suspend to RAM) and WOL (Wake on LAN) has proven very tricky. The PC originally came with Windows Vista and as a business class PC you’d expect these 2 features to work but it has always been a battle to get them working.

Windows 7

Back in the days of Windows 7 I did eventually get both PCs working with Sleep and WOL. Doing so required a lot of fiddling about with drivers and settings so I will detail all the settings that worked for Windows 7 below.

  • Device: Intel 82567LM-3
  • Intel ProSet 22.9.6.0
  • Driver 12.10.12.0
  • Driver Provider: Intel
  • Driver Date: 18/07/2013
  • Power Save Options: All 3 unticked
  • Wake on LAN Options: both ‘Wake on Magic Packet’ ticked and ‘Wake on Pattern Match’ unticked

This driver can be downloaded from softpedia. The driver files are found in the PRO1000\Winx64\NDIS62 subfolder

Some sites also suggest that Intel ME needs to have the correct settings in firmware. This is accessed by Press Ctrl-P at bootup. I checked my settings and they are as follows…

  • Intel ME Configuration: State Control: Enabled
  • Intel ME Configuration: Manageability Feature Selection: Intel Standard Manageability
  • Intel ME Configuration: Intel ME Power Control: Intel ME ON in Host Sleep States: Desktop ON
  • Intel Standard Manageability Configuration: SOL/IDE-r: Enabled
  • Intel Standard Manageability Configuration: Current Provisioning Mode: PKI
  • Intel Standard Manageability Configuration: Host Name: YOUR-PC-NAME-HERE
  • Intel Standard Manageability Configuration: TCP/IP: DHCP Enabled: Y

Once your ME settings are correct, you have the driver above installed, and you have your windows settings correct you should be able to use WOL from sleep when running Windows 7.

Windows 10

Unfortunately the driver used for Windows 7 doesn’t want to be compatible with Windows 10 and so far I haven’t found an alternative that is officially compatible. There is a good thread on the Intel forums that covers the same issue and the poster there has been pretty thorough.

Like the poster on the Intel forums I tried forcing a different driver onto Windows 10 and succeeded in forcing a driver for the i218-LM card which does at least work. However this still didn’t get WOL working.

Hacking the driver

To see if there is any way to get the Windows 7 driver working with Windows 10 I set about hacking the inf file. I did manage to hack it and get it to install although annoyingly this did mean I had to turn off driver signing temporarily. I have detailed the process I used below.

Turn off driver signing (see Windows 10 Tricks for more methods)

  • Click start, expand the arrow next to shutdown, hold the shift key and click restart
  • Select troubleshooting
  • Select advanced
  • Select reboot
  • At the menu that appears after rebooting press the 7 key to disable driver signing

Edit the file e1k62x64.inf

  • Delete line 98
  • Change
    %Intel%     = Intel, NTamd64.6.1, NTamd64.6.1.1, NTamd64.6.2
    
    [ControlFlags]
    ExcludeFromSelect = \ 
        PCI\VEN_8086&DEV_10DE&SUBSYS_10DE8086,\ 
        PCI\VEN_8086&DEV_10DF&SUBSYS_10DF8086

    to

    %Intel%     = Intel, NTamd64.6.1, NTamd64.6.1.1
    
    [ControlFlags]
    ExcludeFromSelect = \ 
        PCI\VEN_8086&DEV_153A,\ 
        PCI\VEN_8086&DEV_153B

Use device manager to do a “have disk” forced driver installation. Then change the same settings as specified for windows 7 above. This worked to install the driver that matches the one installed on Windows 7, but WOL still didn’t work!

Next I need to check each of the ME settings and the Intel driver settings against each other 1 by 1 in the hope that the discrepancy is somewhere in the settings. I do remember having an issue with Windows 7 where I had to find some obscure setting to get it working. I am fortunate to have 2 identical PCs, one with Win 7 and one with Win 10. I will continue to see if I can find a solution and will update this post with anything I find.

I also noticed that a small number of settings seemed to show on the win 10 machine that weren’t present on the win 7 machine. I need to check my driver hack and also remote any previous Intel ProSet that has been installed to try to clear this. I plan to remove proset via programs and features, and also remove and delete the drivers. I will then reinstall the drivers and then run the proset installer (i will check to see how the driver was installed in win 7 – was it driver only or full proset)

Think we’ve missed something? Let us know by commenting below. If you would like to subscribe please use the subscribe link on the menu at the top right. You can also share this with your friends by using the social links below. Cheers.

Leave a Reply

4 Comments

gravatarAMDMan64

I just got this working on an HP dc7900 with an 82567LM-3 adapter on Win 10 Pro 1909.
With the inbox Windows 10 driver, it wouldn’t work and I suspect it’s because that driver doesn’t support the PME setting. If it does, maybe it isn’t exposed.
I downloaded the 22_10 Proset from here:
https://downloadcenter.intel.com/download/27495/Intel-Ethernet-Adapter-Complete-Driver-Pack
Then, extract it.
Select your NIC and do the Have Disk method. Point it to PRO1000\Winx64\NDIS65.
Select the 82579LM Gigabit Network Connection. Continue through the prompt about it being potentially incompatible.
Make sure your network is still working – it works on this system. Driver is dated 7/25/2016 – 12.15.31.4
Under Advanced – make sure that Enable PME is configured and both Wake on Magic Packet and Wake on Pattern Match are enabled.
I have also disabled Fast Startup to make sure that the system shuts down to S5 instead of Hybrid.
I’m not sure if this is required, but HP said to set the following key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NDIS\Parameters
DWORD – AllowWakeFromS5
Value 1
I hope this helps someone out there.

Reply
gravatarJon Scaife

Thanks for your comment, this looks exceptionally useful. I have replaced one of my Dell PCs since I wrote this, but I will be upgrading the other to windows 10 during the Covid lockdown and I will be testing this on it. Thanks again!

Reply
gravatarFL

So far i only managed to allow WOL from shutdown and hibernate in win10 in dell optiplex 760, using proset 25 and windows driver from microsoft update catalog but not from sleep S3. My workaround is to enable ME and use AMT to wake the machine from sleep.

Reply
gravatarHenkV

Thanks AMDMan
I tried your workaround on two Hewlett-Packard HP Compaq 8000 elite desktop PC’s and it works fine.
WOL in Windows10 Pro!
Be sure dis­abled Fast Star­tup otherwise it won’t work.

Reply