1Sonno e WOL con Intel 82567LM-3

I have a couple of old USFF Dell Opti­plex 760 PC that have a built-in Intel 82567LM‑3 gig­abit eth­er­net con­nec­tion. Get­ting this adapter to work with both Sleep (S3 Sus­pend to RAM) e SAL (Wake on LAN) si è dimostrato molto difficile. The PC ori­gin­ally came with Win­dows Vista and as a busi­ness class PC you’d expect these 2 fea­tures to work but it has always been a battle to get them work­ing.

Finestre 7

Back in the days of Win­dows 7 I did even­tu­ally get both PC work­ing with Sleep and WOL. Doing so required a lot of fid­dling about with drivers and set­tings so I will detail all the set­tings that worked for Win­dows 7 sotto.

  • Dispositivo: Intel 82567LM‑3
  • Intel ProSet 22.9.6.0
  • autista 12.10.12.0
  • Driver Pro­vider: Intel
  • Data driver: 18/07/2013
  • Salva Opzioni risparmio energia: Tutti 3 unticked
  • Wake on LAN Opzioni: both ‘Wake on Magic Pack­et’ ticked and ‘Wake on Pat­tern Match’ unticked

This driver can be down­loaded from soft­pe­dia. The driver files are found in the PRO1000\Winx64\NDIS62 sub­folder

Some sites also sug­gest that Intel ME needs to have the cor­rect set­tings in firm­ware. This is accessed by Press Ctrl‑P at bootup. I checked my set­tings and they are as fol­lows…

  • Intel ME Con­fig­ur­a­tion: State Con­trol: Abilitato
  • Intel ME Con­fig­ur­a­tion: Man­age­ab­il­ity Fea­ture Selec­tion: Intel Stand­ard Man­age­ab­il­ity
  • Intel ME Con­fig­ur­a­tion: Intel ME Power Con­trol: Intel ME ON in Host sonno Uniti: Desktop su
  • Intel Stand­ard Man­age­ab­il­ity Con­fig­ur­a­tion: SOL/IDE‑r: Abilitato
  • Intel Stand­ard Man­age­ab­il­ity Con­fig­ur­a­tion: Cur­rent Pro­vi­sion­ing Mode: PKI
  • Intel Stand­ard Man­age­ab­il­ity Con­fig­ur­a­tion: Nome host: LA-PC-NAME-QUI
  • Intel Stand­ard Man­age­ab­il­ity Con­fig­ur­a­tion: TCP / IP: DHCP Enabled: e

Once your ME set­tings are cor­rect, si ha il driver installato sopra, and you have your win­dows set­tings cor­rect you should be able to use WOL from sleep when run­ning Win­dows 7.

Finestre 10

Unfor­tu­nately the driver used for Win­dows 7 does­n’t want to be com­pat­ible with Win­dows 10 and so far I haven’t found an altern­at­ive that is offi­cially com­pat­ible. C'è un filo bene sul Intel for­ums that cov­ers the same issue and the poster there has been pretty thor­ough.

Like the poster on the Intel for­ums I tried for­cing a dif­fer­ent driver onto Win­dows 10 and suc­ceeded in for­cing a driver for the i218-LM card which does at least work. How­ever this still did­n’t get WOL work­ing.

Hacking il conducente

To see if there is any way to get the Win­dows 7 driver work­ing with Win­dows 10 I set about hack­ing the inf file. I did man­age to hack it and get it to install although annoy­ingly this did mean I had to turn off driver sign­ing tem­por­ar­ily. I have detailed the pro­cess I used below.

Turn off driver sign­ing (vedere Finestrini 10 Trucchi for more meth­ods)

  • Fare clic su Start, expand the arrow next to shut­down, tenere premuto il tasto Shift e fare clic su Riavvia
  • Select troubleshoot­ing
  • selezionare avanzata
  • Selezionare riavvio
  • At the menu that appears after reboot­ing press the 7 key to dis­able driver sign­ing

Modificare il file e1k62x64.inf

  • Elimina riga 98
  • Cambia

    to

Use device man­ager to do a “have disk” forced driver install­a­tion. Then change the same set­tings as spe­cified for win­dows 7 sopra. This worked to install the driver that matches the one installed on Win­dows 7, but WOL still did­n’t work!

Next I need to check each of the ME set­tings and the Intel driver set­tings against each oth­er 1 di 1 in the hope that the dis­crep­ancy is some­where in the set­tings. I do remem­ber hav­ing an issue with Win­dows 7 where I had to find some obscure set­ting to get it work­ing. I am for­tu­nate to have 2 identic­al PC, uno con Win 7 e uno con Win 10. I will con­tin­ue to see if I can find a solu­tion and will update this post with any­thing I find.

I also noticed that a small num­ber of set­tings seemed to show on the win 10 machine that wer­en’t present on the win 7 macchina. I need to check my driver hack and also remote any pre­vi­ous Intel ProSet that has been installed to try to clear this. I plan to remove proset via pro­grams and fea­tures, e anche rimuovere ed eliminare i driver. I will then rein­stall the drivers and then run the proset installer (controllerò per vedere come il driver è stato installato nella vittoria 7 — was it driver only or full proset)

Credo che abbiamo perso qualcosa? Fateci sapere commentando qui sotto. Se si desidera iscriversi si prega di utilizzare il link iscriviti sul menu in alto a destra. È inoltre possibile condividere con i tuoi amici usando i link sottostanti sociali. Saluti.

lascia un commento

Uno Commento