0finestre 8 logoPiù WDS errori risolti

WDS è davvero piuttosto un sistema ostile. goffo, poco pratici, e il fallimento ot incline senza informazioni di errore utile. Dopo l'aggiornamento alcuni file incustoditi non ero più in grado di svolgere le installazioni automatiche, ma hanno poi risolto la serie di errori fuorvianti


Ho avuto almeno 3 dif­fer­ent errors, ognuno dei quali sembrano essere correlate. I am using my WDS serv­er without a domain, but as I want to use mul­tiple images (finestrini 7 and win­dows 10) and I want them to be unat­ten­ded, I need mul­tiple unat­tend files.

There is an unat­tend file for the PXE boot stage which sets things like par­ti­tions, e dove seleziono quale immagine io voglio installare. This is linked to the WDS serv­er to make it work with the PXE boot. There have been no prob­lems with this part. This file gets named autounattend.xml after you have linked it to the serv­er

Then each image has an unat­tend file which gets renamed to ImageUnattend.xml and gets put inside the appro­pri­ate image folder. This is where I hit prob­lems.

Sev­er­al key things before you start which will help reduce prob­lems.

1. Do not edit the files in the loc­a­tions the serv­er puts them. keep a copy some­where else, modificare quella copia, and then relink them to the serv­er through the WDS inter­face
2. Restart the WDS serv­er after relink­ing the unat­tend files
3. Think about the per­mis­sions on the RemoteIn­stall share — by default these may not work for non-domain sys­tems. Ho dovuto cambiare il mio

Des­pite hav­ing done all of these things I still got a couple of errors. The first was that my second unat­tend file just seemed to be com­pletely ignored! Ho guardato nei file di log e ho trovato un errore Failed to process client unattend variables. Error code [0x8007000D]. I assumed this was caused by a mis­con­fig­ur­a­tion some­where, but after gen­er­at­ing a new unat­tend file with Win­dows Answer File Gen­er­at­or (an online ser­vice) I then got a new error that setup couldn’t con­tin­ue due to a prob­lem with the answer file. So des­pite the error logs indic­at­ing that my unat­tend file couldn’t be accessed at all, esso infatti potrebbe essere letta, so the fault must have been with the con­tents of the file.

Così ora ho avuto 2 file, né lavorato, but both had dif­fer­ent errors!

I went back to my ori­gin­al file and remove some of the con­tent and tried again. Ha funzionato! A copy of that file is at the bot­tom of this post.

I now had to fig­ure out what the prob­lem was with my ori­gin­al 2 files…

The easi­est of the 2 was the file gen­er­ated by the online ser­vice. Ciò ha incluso una chiave del prodotto, but the product key must be a tri­al key for a retail or oem ver­sion of win­dows 7, and the ver­sion I have uses a MAK key. Make sure you change the product key if you use an answer file from the online gen­er­at­or

The issue with my ori­gin­al file were some com­ments that had been put in it. I don’t know how or when they got there but once removed it worked as expec­ted so make sure you don’t have any com­ments in your file.

Credo che abbiamo perso qualcosa? Fateci sapere commentando qui sotto. Se si desidera iscriversi si prega di utilizzare il link iscriviti sul menu in alto a destra. È inoltre possibile condividere con i tuoi amici usando i link sottostanti sociali. Saluti.

lascia un commento